Linux Support


@usling I don't know why you're having the sound issue.

seems unrelated to the software at play here.

But I gotta say you're boss because the above is exactly what I needed for my new ubuntu 21.04 with an nvidia graphic card (470 driver) !!!

I would get a full black screen except for the game cursor.

adding PROTON_USE_WINED3D=1 to the steam args

and then running
protontricks 9420 dlls d3dx9
protontricks 9420 dlls xact

fixed it for me

plus I have sound.

it's so weird how when you run ubuntu upgrades you don't have any issues with your games but when you install the new OS version from scratch everything breaks. (and this is despite the fact that I'd be migrating proton version and ect)

I guess it just keeps some old files in the system somewhere that do the trick.


So this is what worked for me with fresh installs on both Ubuntu 21.04 and Manjaro with gnome (aug 13 2021) and nvidia 470 driver:

  • Grab a coup of coffee. Maybe some chill music also.
  • Install steam.
  • Install Supreme commander: forged alliance using steam.
  • Enable steam play (steam -> settings -> steam play -> "enable steam play for all other titles" and i set it to Proton 6.3-5
  • Launch options: In steam library, right click Supreme commander: Forged alliance -> Properties...
    Then under "General" -> "Launch options", put PROTON_NO_ESYNC=1, PROTON_DUMP_DEBUG_COMMANDS=1 %command% /windowed 1024 758
    Under "Compatibility" check "Force the use of a specific Steam Play compatibility tool" and choose whatever Proton version you think is best. I went with 6.3 but some ppl say 5.0 is better.

You can try to run the game now, it crashes on launch for me, saying
"CD3DDeviceResources::DevResInitResources: Unable to load effect file /effects/cartographic.fx"

If game runs fine, skip the next section and just edit game.prefs (last step)
If you get that error, close the game and let's fix it.

  • Install winetricks (it will probably also install some dependencies and wine itself)
    ubuntu: sudo apt install winetricks
    manjaro: sudo pacman -S winetricks

  • Install protontricks using this guide:

  • in a terminal, write protontricks 9420 dlls d3dx9

  • in a terminal, write protontricks 9420 dlls xact
    (if you, at a later stage, change proton version in steam, you have to reinstall the above two libraries since they don't seem to come with proton.)

Now start the game. It should start. Create a game profile ingame and exit.

  • edit your Game.prefs
    on ubuntu it's located in:
    ~/.steam/debian-installation/steamapps/compatdata/9420/pfx/drive_c/users/steamuser/Local Settings/Application Data/Gas Powered Games/Supreme Commander Forged Alliance/
    primary_adapter = '1024,758,60',
    to whatever your native screen resolution is, mine is:
    primary_adapter = '2560,1440,60',
    and save.
  • Edit launch options again (see step above) and remove /windowed 1024 758 leaving just PROTON_NO_ESYNC=1, PROTON_DUMP_DEBUG_COMMANDS=1 %command%.

Rune game again and try skirmish.

If you use analogue headphones and have no sound, try change sound output in ubuntu/manjaro gnome from "headphones" to "line out". I've never had any issues with this before, must be some Wine edge case.


You can use my script. Can be fed to the client no problem and used to run faf games.

This will be integrated into the client in the future (tm)
You'll need to set your game location on it etc


My God . can simple steps to install faf and play. to make it just work ...


@yarikchi Doesn't my script work for you (In a few DE's it weirdly doesn't)? I tried to simplify it as much as possible.


@usling it worked for me as well! 😄


After messing around a bit more, I still can't seem to get rid of the issue where the game will jitter/get stuck on a frame for a bit (but noticably) longer than all the other frames. In other words, the game mostly flows at the right frame rate, with quasi regular frame lag every couple of seconds or so. Any suggestions? Thanks!


на 32 бита нет версии?


@esthetics of what? I don't know what you're talking about. FA is 32bit.


Hi everyone.

I got few monthes ago a new computer which is best suited to play SupComm : FA.

I installed Steam on my new computer and have no problem to run forged alliance from steam.
But i can't launch a game or a replay from FAF.
I installed FAF and even try the last version recently (1.6). Faf run without any problems, but when i launch a game from the program, i get an error :

java.lang.RuntimeException: Forged Alliance Crashed with exit code 2. See  for more information
	at$$Lambda$2943/ Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$ Source)
	at java.base/ Source)

My skills are limited, and i can't find a way to fix that problem.
I was wondering if it's because i installed the Flatpak Steam on my linux mint, instead of the regular one. Anyone use flatpak version of steam ?


Did you launch the steam version and make a profile before launching FAF?

A work of art is never finished, merely abandoned


Yes sir. 🙂
And copy the "run" file in the good folder.
I changed de path to be the one used by the flatpak version of steam. But maybe i forgot something ?

If you want to see some logs, just tell me which one and how to get it 🙂

Thanx for your help 😃


@zorglub yes it is indeed because you installed the flatpack version of steam. I recommend you delete that and any leftover steam files

(do not attempt to have a flatpak steam simultaneously with a native steam that is a terrible idea)

if you want to avoid redownloding the games you downloaded, you can take the folder in : steam called "common" that is under "steamapps" (if you right-click on the game in the steam library you can open the folder where the game is installed, then by going up one folder you'll have the "common" folder.) you can move that folder to another place, (say Documents) and then delete steam flatpak and install steam as a native.

when you are here : it gives you the right file.

you can run it by right clicking in empty space in the folder you downloaded steam to then selecting "open in terminal" and in the window that pops up, type in :
(I'm assuming you're on Pop_OS, ubuntu, mint, kubuntu, Zorin,... basically debian based. if not and you're on Manjaro or something like that, you'll have to do something else like sudo pacman -S steam )

sudo dpkg -i steam_latest.deb

(you'll need to type in your password)

then follow the steps and then you'll be able to run steam from your start menu.
make sure to enable proton for all games in the options (steam was completely reinstalled so you need to do everything again)

then you can close steam, move your "common" folder to :

then start steam back up and start the download for the games you previously had installed.

steam will recognize the games are already in the right folder and simply "discover" them instead and then they'll be installed.

then you can try again by giving steam the run arguments I talk about in my video
run FA once from steam, go fetch the run file and put it in your FAF install dir and point to that in the FAF options.

and you should be good to go.


Great, you confirm my suspicion.

i'll try what you suggest when I got some time (i'll need to move other games too) 😃


@zorglub It really doesn't take long at all. the steam download of itself isn't very long.



I successfully got Downlords client up and working finally, but now that I have I can't seem to get it to work. I keep getting Error Code 2, with the error text below.

(I did have some trouble the past two days trying to stay logged in and even connecting, though that issue seems to have subsided as today it went without a hitch but I'm unable to get past this error)

As always, any assistance would be appreciated.

java.lang.RuntimeException: Forged Alliance Crashed with exit code 2. See  for more information
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.base/java.util.concurrent.ThreadPoolExecutor$
at java.base/

Forgive me, I found my mistake. Finally found tatsu's video and found out I needed to point the executible of the run file in the preferences. However, I do have 1 last problem I hope.

I have to start the game in windowed mode. Currently, it runs only in full screen and i only get a black screen with severe lag when moving my mouse from the audio moving over the icons. If i run via steam directly, it uses the /windowed mode just fine, however even after setting windowed mode in the game.pref file (copied and pasted from the windows version that works just fine) It still only opens in full screen.



I am getting the stuck in full screen bug. Is there a fix for it yet?


Hello, I'm having issues launching the client now. Not sure where I'm going wrong. I have the correct JDK installed but I get java errors after the client splash screen closes.

(Edit: Removed log)