Linux Support


@Brutus5000 you could delete .faforever and .com.faforever.client.FafClientApplication in home see if it's not the conf file that's messed up.

if that doesn't do it. regenerate the run file (remove steam.exe like calcifer did)

if that doesn't do it redo your whole FA install.

this is quite weird TBH. never had this. what change happened on your setup before it started failing?


I'm testing new proton 5.13, everything's nominal


Hi everyone,
I'm trying to install downlords faf client on linux. But i'm having problems with java installation.
When i follow the wiki and install openjdk-14-jre (and do all the other steps) i get the following output when trying to run the client:
No suitable Java Virtual Machine could be found on your system.
The version of the JVM must be 15.
Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.

I then tried installing version 15 and setting the env-var with the following:
export INSTALL4J_JAVA_HOME=/usr/lib/jvm/java-15-openjdk-amd64
I also tried to install the oracle java package (as in video tutorial) but i could not get it to install at all.

I am not very experienced in linux... does anyone know what i'm doing wrong?


@JuicyWishes said in Linux Support:

Hi everyone,
I'm trying to install downlords faf client on linux. But i'm having problems with java installation.

open up one terminal window.
first command:
export INSTALL4J_JAVA_HOME=/usr/lib/jvm/java-14-openjdk-amd64
second command:

do you do this or something else?

sorry, the client needs java15 now?


btw i have switched to Windows 10 in this month.
im not proud of this.
but i had basic stability problems constantly. with my recent set up too: PopOS LTS + Gnome3 + AMD drivers.
i dont know why, i have no time to experiment with other things. Win 10 is stable.

so i cannot test the game on linux from now on.
if someone wants to update the wiki from now on, go ahead!


@foodlfg Thats right, thats what i did and i got the output telling me i need java15. but installing java15 did not solve it unfortunately.
I was thinking the environment variable should be different two so i tried changing it to /usr/lib/jvm/java-15-openjdk-amd64 but thats probably wrong.

EDIT: just got it to work. had to use this command:
export INSTALL4J_JAVA_HOME=/usr/lib/jvm/java-15-oracle


Hi everyone!
I've set up the game on latest Manjaro with Steam Play, and I have a couple of questions:

  • game load time seems quite excessive - it takes about a minute to put me into the game and similar amount of time to close the game after I hit exit. Is this usual or can it be improved in some way? (I have tested it using proton 5.0-x and 5.13-x with same results)
  • tried to watch some replays but most of them gave me error message. (I'm not certain it's client related though, as the message seemed to be complaining about a server resource not found. Still like 80% of my tries were unsuccessful which seems like a lot!) So the question: is that normal / can it be improved etc.

Also I've read some from the comments in this topic and the game itself was pretty stable compared to some. I have managed to watch two ~1 hour replays (with max speed) and there were no problems.
Thanks in advance!



takes about a minute to put me into the game and similar amount of time to close the game after I hit exit.

did you use the PROTON_NO_ESYNC=1 flag in Steam before you generated the run file?
without it, it is slow.
probably it is not it. but i have no other idea. the loading wasnt really slow for me.
it may also be a network problem. when you have to connect to other players via the faf server.

as for the replays, same, no idea but make sure you close the game before you start a new replay. can you post the error message?


The PROTON_NO_ESYNC flag is set, yes. I don't think it's network related because I was self-hosting a game with no peers. Did not give any error message either, it just took forever.


As an additional information, I enabled Vulkan support and overlay on the system. With Steam it shows the version info and such but when launching via FAF the corner remains empty. Don't know if that's an indicator of something?


what if you start a terminal and type:
export DXVK_HUD=1
export INSTALL4J_JAVA_HOME=/usr/lib/jvm/java-15-oracle - the usual
./downlords-faf-client - the usual

this should work and you should see the fps numbers etc if you are using Proton 5++. Proton 5++ versions have Vulkan translation enabled by default. so probably you are ok.
but anyways, even with OpenGL translation, it should be faster.

but i see someone modified the wiki to use oracle jdk.
is that ok? i mean open jdk was not good? im concerned about that oracle jdk is not accessible from every of the linux distribution repositories.


Yes, thanks! Overlay and hence vulkan translation appears to be working now. It is still slow though. Joined a game couple of minutes ago and it took like 2.5 mins to start. I was astonished only one dude left till then.


As an aside I was planning to go with openjdk but the specificity of the wiki made me install oracle instead.


Solved! Turned out fsync is enabled by default on newer kernels for Manjaro. Added PROTON_NO_FSYNC=1 to launch options and that did it. It may be advisable to add it to the recommended install process on the wiki since it has no adverse effects.


don't use the new proton_experimental. while it works for FA from steam FA run from FAF fails; this is what you'll get if you try to run it with proton experimental

On another note I'm getting another issue. On my new install of ubuntu 20.10 and with proton 5.13 (in which case the nice error goes away), but my FA stops immediately with no log output as you can see :

2021-01-20 03:53:57.860  INFO 396709 --- [      Thread-24] c.f.client.fa.ForgedAllianceService      : Starting Forged Alliance with command: [/home/t/faf/run, /home/t/.faforever/bin/ForgedAlliance.exe, /init, init.lua, /nobugreport, /log, /home/t/.faforever/logs/game_13674228.log, /gpgnet,, /mean, 1261.25, /deviation, 93.3293, /savereplay, gpgnet://, /country, FR, /clan, BPT, /numgames, 2373] in directory: /home/t/.faforever/bin
wineserver: using server-side synchronization.
2021-01-20 03:53:59.067  INFO 396709 --- [pool-3-thread-5]    : Forged Alliance terminated with exit code 53
2021-01-20 03:53:59.391  INFO 396709 --- [      Thread-24]   : ICE adapter terminated normally

So you haven't made it work on your new setup ever? If that's the case it could be about anything starting with missing dependencies.


yeah but which ones?

and keep in mind it does work from steam.


@tatsu said in Linux Support:

On another note I'm getting another issue.

it is not another issue.
i have mentioned this here before. the run files that Steam generates for newer proton versions dont run the game. the content is different. you can test this easily in terminal with ./your_run_file.

probably Ubuntu LTS and Steam does not play well together.
Proton 5.0 run file was working for me i think, the newer ones did not.


Sounds like it should work. First off I was suspecting some lib32 drivers or blocking loopback but if game runs on Steam it should also run via FAF (as far as my understanding goes). Maybe some stupid typo in FAForever config?


@foodlfg But if he can make it work on Steam then the run file itself should be good no?