UI Party Mod

0

You could try the Supreme economy 2 mod. It does a similar thing but worse imo. You might like that better.

1

@nine2 I would like to collaborate and make brand new version of UI party 😁

My github repo with UI Mods

0

He'll yeah do it bro. What are you going to put in it?

0

@nine2 firstly wanna know what to leave and what to remove from existing mod, and then I add my own stuff 😉

My github repo with UI Mods

0

Decided to give this another try after cleaning my Game.prefs (so much old junk, lol). Is there a way to move the Resource Viewer portion of Econtrol separate from the rest of the UI? I like having the Party menu and Mex list next to my main eco bar at the top left, but then the resource manager extends down, effectively cutting my screen by a third.

0

Nope

0
This post is deleted!
0
This post is deleted!
0

Add few lines to the gamemain.lua in order to fix compatibility with other mods

function OnSelectionChanged(oldSelection, newSelection, added, removed)
		if ignoreSelection then
			return
		end
	--if not SelectHelper.IsAutoSelection() then 
		UnitSplit.SelectionChanged()

		local selectionChanged = UnitLock.OnSelectionChanged(oldSelection, newSelection, added, removed)
		if not selectionChanged then
			oldOnSelectionChanged(oldSelection, newSelection, added, removed)
		end
	--end
end

specifically ignoreSelection stuff

My github repo with UI Mods

0

Has anyone else had an issue with this as of version 2022.6.0? EControl has vanished, and I no longer have the wrench icon to change anything. The other settings seem to remain, like moving the menu buttons to the right and starting with a factory selected. Last time I tried a clean reinstall, all the settings remained, so I was unable to get the wrench back. Attempting to manually remove the mod's settings from my game.prefs resulted in a complete game crash, so I had to reinstall the game in full (lost all my templates & hotkeys).

0

@nine2

  • After the recent patch, all player colors are black (only mod activated + common mod tools)

5ae99c62-a8d4-461d-bb8c-d59ca92a523c-image.png

0

I can't test right now but 2 out of 2 other people have told me they can't replicate your bug. Does it work fine with uiparty disabled?

Doesn't look like something a ui mod can even break.

0

@magge ^^

0

I could pinpoint it to "Start with Player Colors on". If that is selected, every unit in the game will be black after a new game. Friend and Enemies. That was 100% not the case before the last patch(s). I reinstalled the mod again to be sure.

It saved me for every game two thankful clicks, because I always play with those colors enabled.

If they can not reproduce that bug in that way, then something is really odd.

00a3a0a0-e714-4db8-bdc0-1e01bf38c739-image.png

0

Nice work. And presumably team colors itself is fine if you do it manually?

5

@magge You can right click this button:

b370362f-f5a6-4290-a77c-c65484fc2059-image.png

That opens up this:

54788af1-2d7b-4702-8480-f3b8f7ef78b0-image.png

Where you can enable it by default too.

A work of art is never finished, merely abandoned

1

OMG, I did not know you can right-click this icon. I changed the default colors. Thanks Jip.

1

I did not know this either

"The needs of the many outweigh the needs of the few" - Spock

2

@jip Are you kidding me?! I've been using this mod for months, also use player colors as my default setting, and only now do I learn about that setting to fix the black-icons bug. Thank you!